Time404

Astra Linux. Устанавливаем JDK 11.

Как заставить работать приложения, требующие Java (JDK, JRE) в Astra Linux? или продолжаем переваривать наш софт.

 Именно таким вопросом задался я, при установке своего давно любимого IP сканера. 

Тот, кто пользовался такой простой и удобной утилитой, как Angry IP Scanner, тот знает, что для работы она хочет наличия установленной Java или OpenJDK,  последняя так вообще требует 11версию Джавы. 

Астра линукс из коробки на борту имеет только 8 OpenJDK и попытки обновить до 11, как это делал в Ubuntu,  меня ни к чему не привели - возможно криволапость не позволила.

В этот раз поиск по всяческим линукс форумам было долгим и в конце вывел меня на сайт нашей Питерской компании BellSoft и ее продукцию - Liberica JDK.

 

Liberica JDK включена в Единый реестр российских программ для электронных вычислительных машин и баз данных Минкомсвязи РФ

 

И так, чтоб установить нужный нам пакет и версию, заходим на https://bell-sw.com/pages/downloads/

Выбираем то что нам нужно, под наш дистрибутив и скачиваем.

Мне, например, был нужен стандартный JDK 11,  для deb-based дистрибутива, под x86_64 комп.

bellsoftjdk

Скачиваем и запускаем установку:

$ sudo dpkg -i bellsoft-jdk11*

По идее, все ставится легко и гладко

Только один раз, когда тестировал на виртуальной машине, установка закончилась ошибкой зависимостей.

Тогда сделал вот так)) И все пошло как надо))))

$ sudo apt install -f

Angry IP Scanner установлен в систему и больше не ругается

1
RusLan
Комментарии:

Выбрать:

В категории:

Социальные сети:

© 2011- 2022 

Блог Тайм404© - Авторский проект.

Все права защищены. При копировании материалов, активная ссылка на сайт https://time404.ru обязательна.

Внимание! Мы используем cookies чтобы сайтом было удобнее пользоваться.